5ちゃんねる ★スマホ版★ ■掲示板に戻る■ 全部 1- 最新50  

Fink 使ってるの洩れだけなのかっ!?【rev.2】

1 :名称未設定:2006/12/22(金) 18:46:44 ID:m4nUUqkl0
Fink プロジェクトは オープンソースソフトウェアを Mac OS X で使えるようにするものです。
http://finkproject.org/index.php?phpLang=ja

【他のパッケージングプロジェクト】
MacPorts
http://www.macports.org
http://pc7.2ch.net/test/read.cgi/mac/1137291188/l50

pkgsrc
http://www.netbsd.org/Documentation/software/packages.html

EasyPackages
http://www.ie.u-ryukyu.ac.jp/darwin2

649 :名称未設定:2010/06/18(金) 14:58:09 ID:mAoEVjvR0
俺も先週自室をセキュリティーアップデートされてエロ本がごっそり無くなった

650 :名称未設定:2010/06/23(水) 00:45:29 ID:SzPoqzQC0
エロ本が何のセキュリティーに引っかかるのか

651 :baba:2010/06/24(木) 13:33:11 ID:U5VT8pWp0
お母さんに勝手に部屋を掃除された、ってことでしょ。


652 :名称未設定:2010/06/26(土) 12:07:45 ID:Ub6xB3Iy0
まさかのマジレス…

653 :名称未設定:2010/06/27(日) 12:56:30 ID:0abRHXsC0
お母さんは掃除をしたのではない
今後危険となる単純所持の可能性を排除したんだよ

654 :名称未設定:2010/06/29(火) 01:08:05 ID:YgbKwkJo0
そういうヤバイやつだったのか
なるほろ

655 :名称未設定:2010/07/04(日) 00:44:53 ID:6CDtg9CW0
finkもOpenCVをlistに載せちゃいなよ

656 :名称未設定:2010/08/09(月) 17:18:58 ID:NkvlrY3f0
あげ

657 :名称未設定:2010/09/29(水) 01:36:13 ID:SWdKDmJJ0
Is Fink dead?

Finkって生き返らないかな。MacPortsなんかより全然良いのに。もっとメンテナ増えて欲しい、、。

658 :名称未設定:2010/09/29(水) 23:57:29 ID:tErNv75VP
fink って死んだの?
毎日使ってるので、なくなると困るんだが。

659 :名称未設定:2010/09/30(木) 14:36:59 ID:shDpLFbj0
すみませんmacportsに乗り換えちゃいました

660 :名称未設定:2010/10/01(金) 12:51:44 ID:5vujemrF0
全然死んでいないでしょう。
俺は特に困っていないんだが、何が問題?

661 :名称未設定:2010/10/05(火) 13:24:29 ID:axbTzViP0
そもそも、Unix系のソフトをそんなに頻繁に出し入れしないんで、
思い出したとき使おうと思ったら、Finkがあったって感じです。
だから、Finkってよく分からないんでこのスレ読んでいます。

662 :名称未設定:2010/10/07(木) 02:26:48 ID:0rVG26uP0
fink
地道にアップデートしてくれてるよ
ごくろうさまです

663 :名称未設定:2010/10/09(土) 11:08:09 ID:ziRRK1Y40
>>657
既にあるパッケージをマイナーアップデートするだけだったら、
Unix の知識ほぼゼロでもできるよ。

>>662
されてますね。
「これ、ぜんぜん更新されないな」と思ってたら
package -> package5 みたいに名前の違う
新しいパッケージになってたり。

664 :名称未設定:2010/10/11(月) 15:51:16 ID:B8SC6mxH0
今更ながら、日本ユーザーズグループを作るとか。


やること特にないけど、、

665 :名称未設定:2010/10/22(金) 04:19:42 ID:Ow7zb0P50
マルチコアのCPUで並列にbuildさせるのってどうやるの?
make -j 4 に相当するようなこと。

666 :名称未設定:2010/10/27(水) 00:04:50 ID:oUh4VRZY0
シェルで環境変数設定するなり、エイリアス作るなり、、
じゃないの?

667 :名称未設定:2010/12/01(水) 11:30:08 ID:HFPJ14no0
師走なんで、保守。

668 :名称未設定:2010/12/02(木) 12:47:21 ID:QypleDfY0
10.5.8 ppc ibookg4
python 26-2.6.6-1がcompile errorでこけちゃって
「selfupdateして駄目ならFAQ見てみる?」みたいな駄目ぽなメッセージしか残さないんですけど
macbook買えとか以外で良い手を知ってる人居ますか?

669 :baba:2010/12/03(金) 09:43:13 ID:SMyDiLGS0
>>668
・selfupdate はしましたか?その前にしたのはいつ頃ですか?
・エラーメッセージを「長めに」コピーして、どこかにアップしてください。
・python27 や python31 ではどうでしょう?

670 :名称未設定:2010/12/03(金) 14:00:02 ID:FoO/n+uz0
selfupdateをして、python以外のoutdatedをアップデートしたら最終的には以下の様なエラーメッセージになりました
macportみたいにno_tkみたいなことをしなくちゃいけないのでしょうか?

Failed to find the necessary bits to build these modules:
bsddb185 linuxaudiodev ossaudiodev
spwd sunaudiodev
To find the necessary bits, look in setup.py in detect_modules() for the module's name.
(Fink package build should have 5 missing)

Failed to build these modules:
_tkinter

make: *** [sharedmods] Error 1
### execution of /var/tmp/tmp.1.Cswo5j failed, exit code 2
Removing runtime build-lock...
Removing build-lock package...
/sw/bin/dpkg-lockwait -r fink-buildlock-python26-2.6.6-1
(Reading database ... 64501 files and directories currently installed.)
Removing fink-buildlock-python26-2.6.6-1 ...
Failed: phase compiling: python26-2.6.6-1 failed

Before reporting any errors, please run "fink selfupdate" and
try again. If you continue to have issues, please check to see if the
FAQ on fink's website solves the problem. If not, ask on the fink-users
or fink-beginners mailing lists, with a carbon copy to the maintainer:

Daniel Macks <dmacks@netspace.org>

Note that this is preferable to emailing the maintainer directly, since
most fink package maintainers do not have access to all possible
hardware and software configurations.

671 :名称未設定:2010/12/03(金) 14:12:41 ID:FoO/n+uz0
前回のアップデートは1〜2か月前だと思います。
python26,27はダイブ前からinstall済みです。31に関しては現状では入れてません。
アップデート前のpython26が問題なく動いているので、次のアップデートまで気長に待つ事は可能です。

672 :baba:2010/12/03(金) 16:16:48 ID:SMyDiLGS0
>>670
ひょっとして、Fink 以外の
自分でビルドした/MacPorts の Python とかあります?

673 :baba:2010/12/03(金) 16:25:06 ID:SMyDiLGS0
あと、エラーだけではなく、その直前からコピーしてください。
エラーだけではほとんどわからないです。

674 :baba:2010/12/04(土) 11:01:46 ID:70o/apBi0
Python メンテナの Daniel と話しました。同様のエラーは、ユーザーが Fink 以外で X11 を改変した際にあったそうです。
あなたは、例えば MacPorts などで Tk などをインストールされていませんか?おそらくそれが原因だと思われます。

また、
$ fink -k build python26
として作成される、
/sw/src/fink.build/python26-2.6.6-1/Python-2.6.6/config.log
をbabaまでメールで送ってください。メアドは、、調べたらすぐわかるかと。

・基本的に、これは Fink 外で起こったことに影響を受けています。
・config.log を送って頂ければ、Fink Project でも調査をし、エラーが出ないよう努力しますが、できる保証はありません。
・基本的に、Fink を使う限りは MacPorts などと併用しない方がよいです。Macを買い替えたとしても、同じ問題は起こると思います。

よろしくお願いします。


675 : [―{}@{}@{}-] 名称未設定:2010/12/04(土) 11:50:16 ID:CCfvbKgCP
最近 fink update-all すると以下のエラーが出るんですが…
Can't resolve dependency "system-java-dev" for package "ppl-0.10.2-3" (no
matching packages/versions found)


676 :baba:2010/12/04(土) 12:10:00 ID:70o/apBi0
>>675
質問6.17: Fink が Failed: Can't resolve dependency "system-java14-dev" と言っていますが、そのようなパッケージはありません。

回答: バーチャルパッケージだからです。 このエラーは、 Java が Software Update によって更新された場合に発生します。 更新時にヘッダファイルが削除され、 -dev パッケージが作成されなくなるためです。

Apple (http://connect.apple.com/) から、適切な Java Developer Tools パッケージをダウンロードする必要があります。 この問題の場合は、 Java 1.4.2 Developer Tools です。

http://www.finkproject.org/faq/comp-general.php?phpLang=ja#system-java

677 :baba:2010/12/04(土) 12:17:14 ID:70o/apBi0
ま、ようは Apple の Software Update に問題があるみたいです。

# しかし、自分「基本的に」って言葉好きだなぁ。

678 : [―{}@{}@{}-] 名称未設定:2010/12/04(土) 12:26:22 ID:CCfvbKgCP
>>676,677
さっそくありがとうございました。
Javaをアップデートしてみます。

しかし、Fink はこんなに使いやすい(+ babaさんのサポートまである)
のにあまり流行ってないようなのはどーしてなんでしょう。

679 :baba:2010/12/04(土) 12:35:55 ID:70o/apBi0
たぶん、フリーソフトウェアって、よほど大きなバージョンアップがあるか、逆に問題がでたときくらいしか
ブログやら何やらに書き込まない傾向があって、Fink は大きなバージョンアップも大きな問題もないので、
話題に上らないだけ、、、だと信じています。

680 :名称未設定:2010/12/06(月) 10:54:40 ID:ahsEqOGh0
>>674
丁寧な回答ありがとうございました。
確かにtkを自分で読み込むアプリが一つ入ってます。
今後の事を考えてこのアプリがfinkのtkのバージョンで動くか確認してから
ごにょごにょとしてみたいと思います。
誠に勝手ながら、行き詰った場合はお言葉に甘えてメールしたいと思います。
指針を頂きありがとうございました。

681 :名称未設定:2010/12/15(水) 12:41:38 ID:CWzPB8pa0
浮上

682 :名称未設定:2011/01/01(土) 22:14:02 ID:TZI7JLM10
初心者の質問で申し訳ありません。
本家サイトのPackage Datebaseにあるソフトはバイナリでインストールできると思って良いのでしょうか?
もしくは、現在OS10.6.5ですでにMacPortsが入ってますが、apt-cache searchするためにFinkをソースインストールするのは危険でしょうか?

683 :baba:2011/01/03(月) 14:42:03 ID:KaBmgVLH0
・Package Database に、バイナリがあるかどうか明示されています。
http://pdb.finkproject.org/pdb/package.php/apt
このパッケージは、10.5 までならバイナリがそろっています。

・10.6 はバイナリ配布していません(できていません)。

684 :682:2011/01/03(月) 21:40:22 ID:hOQ3ZcO30
>>683
わかりました。ありがとうございます。

portsの方が何度目かの全消しのハメになったので、一度Fink試してみます。

685 :名称未設定:2011/01/10(月) 19:04:57 ID:1uhhx8xr0
MacOSX 10.6.6 です。
$ fink update-all すると
Failed: PatchFile "/sw/fink/dists/unstable/main/finkinfo/gnome/pango1-xft2-ft219.patch" checksum does not match!
Actual: b36bfe92f3f7b983971ad8f7e1370139
Expected: 6ded4ab5241c6db1c183005ab89f4b21
と出て止まっちまうんですが、これ、どうすればいいんですか?
一旦、この PatchFile を捨てちゃってリトライ、でいいんでしょうか?

686 :名称未設定:2011/01/10(月) 22:27:16 ID:Y+yoMLJB0
>>685
今は直ってるよ。fink selfupdate してもう一度トライしてみて。

687 :名称未設定:2011/01/11(火) 02:06:52 ID:sDU62sdg0
>>686
どうもありがとうございます。
さっそく fink selfupdate して fink update-all してみたのですが、やっぱり
Failed: PatchFile "/sw/fink/dists/unstable/main/finkinfo/gnome/pango1-xft2-ft219.patch" checksum does not match!
Actual: b36bfe92f3f7b983971ad8f7e1370139
Expected: 6ded4ab5241c6db1c183005ab89f4b21
と出ます。
これ、上記とまったく同じエラーですよね。
うううむ。どうしてなのかな。。。

688 :名称未設定:2011/01/11(火) 15:08:20 ID:8umfsv7R0
>>687
おかしいな。cvs のログによると、
/sw/fink/dists/unstable/main/finkinfo/gnome/pango1-xft2-ft219.info
の該当箇所は、去年の夏(2010/08/23)にちゃんと直されてる。
そちらの pango1-xft2-ft219.info が更新されてない可能性が大。
今の情報だけだと何が原因かはわからないが……

rsync のサイトはどこ使ってる?ちなみに自分の /sw/etc/fink.conf には
Mirror-rsync: rsync://hnd.jp.asi.finkmirrors.net/finkinfo/
と書いてある。

あとちゃんと Trees: のところに unstable/main は登録されてる?

689 :名称未設定:2011/02/08(火) 11:44:18 ID:1rOkohJm0
fink selfupdate-rsync で proxy を使うにはどうしたら良い? cvs サーバが動いていないので、rsync に変更したいけど、firewall があるので…

690 :名称未設定:2011/02/08(火) 18:31:38 ID:DQtSueYn0
>>689
やったことないけどググったらこんな感じみたいよ
ttp://d.hatena.ne.jp/afro/20070708
ttp://superuser.com/questions/138779/how-to-install-fink-when-behind-proxy

691 :名称未設定:2011/02/14(月) 23:10:31 ID:hYE7DVt90
MacOSX 10.6.6 なんですが、
fink update
fink selfupdate
したのち
fink update-all
をかけると
Failed: file download failed for lame-3.98.4.tar.gz of package lame-3.98.4-1
でコケます。
どの mirror でも見つからないようで、
ミラー探しのダイアログには、
すべて 4(別のミラーを探す)を答えてるんですが、
ダメです。
lame-3.98.4.tar.gz ってどうなってるんでしょう。
普通にウェブで検索したら見つかったんで、
これ自体は落とせたんですが、
fink install ./lame-3.98.4.tar.gz
ってやってもインストールできないんですよね。
apt-get install ./lame-3.98.4.tar.gz
もダメだった。
こういう時ってどうすればいいんでしょう?

692 :名称未設定:2011/02/16(水) 13:33:53 ID:Uh3vBrTT0
>>691
ダウンロードしたソースを適切な格納場所(普通 /sw/src 下)に置けばいいと思う。


693 :名称未設定:2011/02/16(水) 18:17:50 ID:ADc8DS170
>>692 サンキュ!通った。通りました。ありがとう!

と、思ったが、

Failed: can't batch-install packages:
/sw/fink/dists/unstable/main/binary-darwin-i386/languages/guile18_1.8.7-1_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/languages/guile18-shlibs_1.8.7-1_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/languages/guile18-libs_1.8.7-1_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/languages/guile18-dev_1.8.7-1_darwin-i386.deb

と出た(実際は改行なしの一行で) orz

なんかこの4つのバッチファイルのインスコでこけてるみたいなんだけど、
そもそも guile18 なんていつ何で入れたのか忘れちまったので、

fink remove guile18

で除去した。そんでもういっかい

fink update
fink selfupdate
fink update-all ← いまここ

694 :693:2011/02/16(水) 20:55:27 ID:ADc8DS170
延々続くアップデートが終わったと思いきや、
Failed: Fink::SysState: Could not resolve inconsistent dependencies
と出てた。 orz

fink scanpackages
sudo apt-get update
sudo apt-get install autoconf2.6=2.68-1

せいと言われたのでやって、再度

fink update
fink selfupdate
fink update-all ← いまここ

695 :693:2011/02/16(水) 21:10:56 ID:ADc8DS170
今度は

Failed: can't batch-install packages:
/sw/fink/dists/unstable/main/binary-darwin-i386/sound/esound_0.2.41-2_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/sound/esound-shlibs_0.2.41-2_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/sound/esound-bin_0.2.41-2_darwin-i386.deb
/sw/fink/dists/unstable/main/binary-darwin-i386/sound/esound-common_0.2.41-2_darwin-i386.deb

と出た。 orz

fink remove esound

して、再度

fink update
fink selfupdate
fink update-all ← いまここ

696 :693:2011/02/17(木) 03:14:26 ID:1brPCUQM0
以下のパッケージの処理中にエラーが発生しました:
fink-buildlock-python25-2.5.5-104
### execution of /sw/bin/dpkg-lockwait failed, exit code 1
Can't set build lock for python25 (1:2.5.5-104)

orz...


fink remove python25
とやったら

以下のパッケージの処理中にエラーが発生しました:
python25
### execution of /sw/bin/dpkg-lockwait failed, exit code 1
ERROR: Can't remove package(s). If the above error message mentions dependency problems, you can try
fink remove --recursive python25
This will attempt to remove the package(s) specified as well as ALL packages that depend on it.
Failed: can't remove package python25

と出ました

orz...

fink remove pycairo-py25-dev
fink remove python25 pyorbit2-py25 pygtk2-gtk-py25 pycairo-py25 scipy-core-py25 pygobject2-py25 pdflib-py25 numeric-py25 libxml2-py25

fink update
fink selfupdate
fink update-all


← いまたぶんこのあたり

697 :名称未設定:2011/02/17(木) 05:56:53 ID:ka6sRk2Q0
英語読めないの?

698 :693:2011/02/17(木) 07:50:34 ID:1brPCUQM0
あああああごめん。いま気付いた。 orz

fink remove --recursive python25

何回も同じようなメッセージばっか出て段々注意力が落ちてる。
そゆことってない?ないか。

699 :名称未設定:2011/04/13(水) 13:22:03.25 ID:2N17TvCA0
hnd.jp.asi.finkmirrors.net
につながらないのですが、運用終了でしょうか。

700 :名称未設定:2011/04/14(木) 19:53:34.60 ID:SGmkVBoA0
何故ここで聞けば答えが解ると思っているのか。

701 :名称未設定:2011/04/15(金) 15:00:52.64 ID:Jl6F5BHu0
答えが解ればラッキーと思っているだけで、解ると断定的に思っている部分は微塵もございません。
ttp://www.finkproject.org/links.php?phpLang=ja
でもここ (の古いURL) が紹介されてますし、東大 Fink チームのウェブサイトもつながらないから、finkATsodan.ecc.u-tokyo.ac.jpが生きてるのかどうかも解らない…。

702 :名称未設定:2011/04/17(日) 10:39:23.05 ID:TMonHE4d0
Fink をアップグレードしようとして /sw2 に入れてみたけど
FinkCommander はデフォルトで /sw を見に行くようで
毎回 /sw2 を見るよう設定しないといけないようだがどうにかならないものか
あと、インストールしても「インストール済」のバージョンが変わらない
古い方(/sw)を見に行ってるのだろうか?

703 :名称未設定:2011/04/18(月) 13:50:40.39 ID:RhevXTNc0
>>699
動かしたいのは山々なのだが、東大から節電の通達があり、三月中旬から
Webサーバ http://fink.sodan.ecc.u-tokyo.ac.jp/ を含む多くのサーバがシャットダウンされてる。
hnd.jp.asi.finkmirrors.net はそのサーバ宛だからつながらない。こればかりはどうしようもない。
メールサーバ(別のマシン)はさすがに生かしてくれているが……。

704 :名称未設定:2011/04/18(月) 16:38:20.23 ID:qog5p36N0
なるほど。そういう事情でしたか。
ご説明戴きありがとうございました。

705 :名称未設定:2011/04/21(木) 11:16:35.77 ID:m8NbU40a0
>>702
アンインストールしちゃったから見られないけど環境設定に見に行くディレクトリ設定できなかったっけ?
前64bitと分けてたときはsw64とかにしてちゃんと動いてたと思うんだけど。

706 :名称未設定:2011/05/04(水) 03:03:35.24 ID:d5T97gGa0
その設定が保存されないっぽ

707 :名称未設定:2011/05/15(日) 07:47:40.27 ID:XQsnj6zp0
バイナリパッケージが提供されないfinkなんていらない

708 :名称未設定:2011/05/15(日) 14:30:05.61 ID:TE0mXmIx0
ソースを落としてビルドする、また楽しからずや

709 :名称未設定:2011/05/22(日) 00:42:48.83 ID:gGfmKPtD0
たまに依存性で三すくみ
いとおかし

710 :名称未設定:2011/05/22(日) 13:24:15.69 ID:Q8YD8OJ40
lftpはもうちょっと新しいのにしてほしいなぁ。とりあえず、dirしてコアダンプは困る。

711 :baba:2011/05/23(月) 11:10:06.05 ID:IBiZw48d0
>>710
>lftpはもうちょっと新しいのにしてほしいなぁ。とりあえず、dirしてコアダンプは困る

最新バージョンのパッケージを作ってみました。
http://fink.cvs.sourceforge.net/viewvc/fink/experimental/babayoshihiko/finkinfo/lftp.info?revision=1.1&view=markup

712 :baba:2011/05/23(月) 11:15:23.77 ID:IBiZw48d0
これを、/sw/fink/dists/local/main/finkinfo にコピーして、インストールしてみてください。
うまく行くようであれば unstable にアップします。
ダメだったら、fink remove した後で、このファイルを消したらunstable バージョンをインストールできます。

713 :名称未設定:2011/05/24(火) 01:59:29.16 ID:L3BMf+i80
>>712
ありがとうございます。
残念ながら、挙動は変わりませんでした。
$ uname -a
Darwin squirrel.local 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; root:xnu-1504.9.37~1/RELEASE_I386 i386
です。

$ env ja_JP.UTF-8 lftp ftp://ftp.jaist.ac.jp/pub/Linux/Fedora/development/
cd 成功、cwd=/pub/Linux/Fedora/development
lftp ftp.jaist.ac.jp:/pub/Linux/Fedora/development> dir rawhide/source[tab]
はコアダンプしますが、
$ env en_US.UTF-8 lftp ftp://ftp.jaist.ac.jp/pub/Linux/Fedora/development/
cd ok, cwd=/pub/Linux/Fedora/development
lftp ftp.jaist.ac.jp:/pub/Linux/Fedora/development> dir rawhide/source[tab]
は正常に動作します。

ここまでの違いは、「cd 成功、」か「cd ok, 」か、です。
lftpがマルチバイト文字をうまくの処理できてない?

714 :baba:2011/05/25(水) 21:17:09.02 ID:NysJOvSi0
更新しました。URLは >>711 と同じです。
baba$ LC_ALL=ja_JP.UTF-8 lftp ftp://ftp.jaist.ac.jp/pub/Linux/Fedora/development/
cd 成功、cwd=/pub/Linux/Fedora/development
lftp ftp.jaist.ac.jp:/pub/Linux/Fedora/development> dir rawhide/source/SRPMS/

715 :baba:2011/05/25(水) 21:37:14.28 ID:NysJOvSi0
嘘着きました。こっちです。
http://fink.cvs.sourceforge.net/viewvc/fink/experimental/babayoshihiko/finkinfo/lftp.info?revision=1.2&view=markup

716 :名称未設定:2011/06/03(金) 01:42:24.25 ID:lwPwlIG60
>>715
遅くなりましたが、試してみました。
$ env LC_ALL=ja_JP.UTF-8 lftp ftp://ftp.jaist.ac.jp/pub/Linux/Fedora/development/
cd 成功、cwd=/pub/Linux/Fedora/development
lftp ftp.jaist.ac.jp:/pub/Linux/Fedora/development> dir rawhide/source[tab]
でコアダンプします。

ただ、ターミナルのサイズが80x24の時はコアダンプしますが、179x53では表示が若干おかしいもののコアダンプはしませんでした。
Fedora 15のlftpでは発生しない問題なので、finkかMacOS X側 (のlftp以外の部分) の問題だと思います。

~/.profileには
test -r /sw/bin/init.sh && . /sw/bin/init.sh
しか設定していません。

717 :名称未設定:2011/06/16(木) 01:15:42.64 ID:E1ndc3T30
Panther機引っ張り出してFinkで遊ぼうと思ってます。
そこでX11(xFree86 or xorgを予定)なのですが、ドキュメントを読むと、
Finkで入れても公式ソース/バイナリどちらでも良いとあります。
しかしFink版は独自のパッチがあたっています。これはどう考えれば良いのでしょう?
どちらでもOKということは、Fink版パッチの存在意義はどこにあるのでしょうか?
体勢に影響を及ぼさないパッチなのでしょうか?

718 :baba:2011/06/16(木) 13:22:36.14 ID:NERHOtao0
昔は公式 X11 に問題が多かったので、Panther 頃までは Fink 版の X11 がありました。
Fink 版の方が新しいバージョンでしたが、Panther でも、ほとんどの人が公式 X11 を使っていたと思います。

719 :名称未設定:2011/06/16(木) 20:48:20.69 ID:E1ndc3T30
早々にありがとうございます。
FinkのDocumentを読み誤っていたのでしょうか?
FInkがサポートするX11は、
・Apple X11
・xFree86 4.4.x built via Fink (おそらく4.5.0もですね)
・X.org built via Fink
この3種のみ。
例えばxFree86 4.4.0 の公式バイナリや、xorg6.8.2の公式ソースから自分でビルドは
Finkでは認めていない。と考えればいいのでしょうか?




720 :名称未設定:2011/06/16(木) 22:49:56.41 ID:pvle94Da0
>>719
Finkを使う時は基本的にすべてFink任せにして他の物は混ぜない方が整合性がとれる。
Finkに無い物はしょうがないけどね。

721 :名称未設定:2011/06/16(木) 23:16:58.17 ID:E1ndc3T30
それは理解しているのですが、

Running X11 - 3. X11 の入手とインストール
http://www.finkproject.org/doc/x11/inst-xfree86.php?phpLang=ja)
3.3 公式バイナリ
XFree86 プロジェクトには公式の Xfree86 4.5.0 バイナリディストリビューションがあります。
・・・・Xinstall.sh スクリプトを root で実行してインストールします。
(※darwin7用バイナリは4.4.0しか無い事は承知しています。)
3.4 公式ソース
もし時間が許せば、 XFree86 4.5 はソースからビルドすることもできます。
・・・・以下のコマンドで XFree86 をコンパイルしてインストールしましょう。

という記述があります。
つまりFink独自パッチがあたっていてもいなくても関係なく思えました。
公式のバイナリやソースから自分でインストールしようが、Finkでインストールしようが
その後に影響ないという事でしょうか?
影響無いならFinkのパッチの存在意義は?
影響有るならこのDocumentの言わんとしてる事は?
という質問なのです。


722 :名称未設定:2011/06/17(金) 00:22:31.73 ID:QQTTxDFy0
>>721
Pantherの頃はどうだったのかねぇ。今はX.orgからバイナリを入手する事になってるんだけど。
Xプロジェクトの方も分かれたりくっついたり看板が変わったりでわけ判らん状態でもあるし。
パッチは無くても良いって解釈で良いんじゃね。

723 :baba:2011/06/17(金) 10:01:15.85 ID:vxx0eq7R0
>>721
>影響無いならFinkのパッチの存在意義は?
「Fink 版 の X もある」という存在意義じゃないですかね。

724 :名称未設定:2011/06/21(火) 23:47:22.04 ID:LY/ZlUFq0
正直引きました。

公式から持ってきて自分で入れても良いけど、選択肢が増やす為Fink版も用意したよ。
公式と同じじゃ芸が無いから独自パッチ付きだけど、有っても無くても影響無いよ。

て事ですね。
要はメンテナの自己満足の為で、その結果無駄に複雑にしたと。

>>722
ありがとうございます。

725 :名称未設定:2011/06/22(水) 01:43:35.00 ID:jOq5Ats30
>>724
そう感じたならFinkに頼らず自分で全部ビルドすると幸せになれると思うよ
今後はそうするつもりなんだろうと思うけど

726 :名称未設定:2011/06/22(水) 17:23:42.06 ID:yjKwJJtP0
XQuartzで何が駄目なのかわからん

727 :名称未設定:2011/06/22(水) 20:22:47.98 ID:fXP0WGGE0
>>724
>要はメンテナの自己満足の為
Apple が作ってた X11 は 10.4 くらいまでは本当に不安定で、それを Fink の開発者たちが直して、
Fink ユーザーがテストして、その直した部分を Apple や X.org に送って、ってことをやってきたんだよ。
X11 に限らず、MacOSX のソースの中にもFink 開発者が作ったものだってたくさんあるんだから。
それを「自己満足」で片付けられたら、こっちの方が引くわ。

728 :名称未設定:2011/06/22(水) 20:25:01.48 ID:fXP0WGGE0
ちょっと正確じゃなかった。
もともと10.4までは、X.orgのものもAppleのものバグが多かった。
Fink 開発者を含め、多くの人 (Apple 社員、Fink、X.org、Portsの人たち、その他大勢)が共同して直していたんだよ。
その点を理解していないようだね。

729 :名称未設定:2011/06/22(水) 22:40:05.99 ID:bzMfC9F+I
ってかこいつパッチが何なのかわかってないだろ。

730 :名称未設定:2011/06/24(金) 11:00:27.35 ID:AHn4JXoM0
パッチってのは、「このソフト日本語に対応していないから、日本語対応させるパッチつくりました」
ってまもんで、それは日本語使わない奴らからしたら「自己満足」なパッチ。
もともとそういう自己満足の集まりがフリーソフトウェアなんだから、
まぁ、>>724 が一いることは間違いではない。ただ、フリーソフトウェアの意義を知らないな。

731 :名称未設定:2011/08/26(金) 11:05:45.93 ID:wW975O8R0
fink selfupdate

732 :名称未設定:2011/09/11(日) 02:40:19.74 ID:PvWSSPvt0
10.7対応はどんな様子かな

733 :baba:2011/09/13(火) 15:47:33.71 ID:ejFv/QLR0
10.7 ディレクトリにあるパッケージは問題なし。
unstable はなくなり、stable 一本になる予定。
個人的には Qt がまだ使えないのが残念。

734 :名称未設定:2011/09/13(火) 21:01:24.58 ID:Hjmaxa7y0
情報サンクス
そろそろMBAに入れてみるかな

735 :名称未設定:2011/09/16(金) 21:00:23.22 ID:56tfA9fp0
>>733
qt4-base-{mac,x11} はもう入ってるよ。
でもemacsがない…。

736 :名称未設定:2011/10/06(木) 23:03:14.70 ID:RuKN4IosP
ジョブズの訃報を聞いて、おもわず新しい MacBook を買ってきました。
Lion は使いやすくて良いんですが、Lion 用の fink に emacs が入るのは
まだ時間がかかりそうでしょうか?

東大 fink チームも web が更新されていないようですし、少し心配です。

737 :baba:2011/10/07(金) 10:51:16.89 ID:6pkB0jbU0
>>736
ひとまず Aquamacs でどうでしょう。

738 :736:2011/10/07(金) 18:48:12.87 ID:nrDOJdjYP
>>737
ありがとうございます。Aquamacs というのは知りませんでした。
Aquamacs やコンパイル済み Emacs の配布物などを使えばいいのですが、
elisp パッケージのインストール(とその後の管理)がめんどくさいですね。
fink は elisp パッケージも管理できるので、とても重宝していたのですが。

739 :baba:2011/10/11(火) 20:23:10.38 ID:QIFur9lT0
ようやく Emacs が 10.7 に登場したようです。これで elisp 関連も徐々にそろうでしょう。
10.7 からは、 unstable と stable に分けるのをやめ、 stable 一本に統一するようです。
といっても別に良いニュースという訳ではなく、メンテナが少ないための苦肉の策です。
また、10.4 のサポートもどんどんなくなっていくと思われます。


740 :736:2011/10/11(火) 22:22:15.05 ID:77hmu+HYP
>>739
そうですか、それは朗報です。
ちなみに Aquamacs は flim がコンパイルできずにあっさり断念して、
Emacs23 のバイナリ配布版(+ ports)を使っていました。

しかし、メンテナが少ないというのは残念ですね。
なにか協力できることがあれば良いのですが。

741 :baba:2011/10/12(水) 11:30:49.39 ID:ygsmjMyD0
パッケージを直せるようでしたら、直してくれるのが一番ですね。
定期的につくる時間が取れるなら、SourceForge でアカウントとってもらって、
http://fink.cvs.sourceforge.net/viewvc/fink/experimental/
という CVS サーバーを使えるようにできると思います。
(ただ、Fink の git への移行話でいま盛り上がっていますが)

742 :名称未設定:2011/10/25(火) 12:20:28.47 ID:yIKxFfZ80
早くgitへ移行しないかなぁ。

743 :baba:2011/11/01(火) 19:58:42.63 ID:osApzGqD0
git って、どういいんですか?

744 :名称未設定:2011/11/01(火) 21:53:37.43 ID:u3KGOJke0
git 手を見る

745 :名称未設定:2012/01/22(日) 12:31:57.81 ID:wLMo14Kc0
test

746 :名称未設定:2012/02/25(土) 15:01:54.38 ID:Wmqk0cgD0
finkって元カノみたいな存在だよな

747 :名称未設定:2012/02/26(日) 01:08:26.08 ID:4vpgYBnvP
東大finkチームって、活動やめちゃったんでしょうか?

748 :名称未設定:2012/02/26(日) 01:36:34.06 ID:0K+iMfGX0
直接聞けハゲ。引き継ぎがいないと数年もすれば消える

749 :baba:2012/03/06(火) 13:57:23.62 ID:JW5G6zJA0
Fink 的には東大生である必要はまったくないので、
そろそろ「自分もやります」って言う人が来てほしいですね。


241 KB
新着レスの表示

★スマホ版★ 掲示板に戻る 全部 前100 次100 最新50
名前: E-mail (省略可) :


read.cgi ver 05.04.00 2017/10/04 Walang Kapalit ★
FOX ★ DSO(Dynamic Shared Object)